package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([0-9]{4})-([0-9]{2})-([0-9]{2})T([0-9]{2}):([0-9]{2}):([0-9]{2})(.[0-9]+)?(Z|([+-](([0-9]{4})|([0-9]{2})|([0-9]{2}:[0-9]{2}))))$`)
var str = `2016-09-27T22:07:57+0000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}