re = /^([0-9]{4})-([0-9]{2})-([0-9]{2})T([0-9]{2}):([0-9]{2}):([0-9]{2})(.[0-9]+)?(Z|([+-](([0-9]{4})|([0-9]{2})|([0-9]{2}:[0-9]{2}))))$/
str = '2016-09-27T22:07:57+0000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end