#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi) of (?!course)"
Local $sString = "OF" & @CRLF & _
" OF " & @CRLF & _
" of " & @CRLF & _
"text with of in text" & @CRLF & _
" of course" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"fo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")