$re = '/ of (?!course)/mi';
$str = 'OF
OF
of
text with of in text
of course
fo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);