package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)public_key=#STARTKEY#(.*)#ENDKEY#`)
var str = `public_key=#STARTKEY#c3NoLXJzYSBBQUFBQjNOemFDMXljMkVBQUFBREFRQUJBQUFCZ1FEWVZVZDY5eVBDS2hvejdjMUI5
dWx0TStNZmpRR3BnZG9xZGhFTDRKVStsRkt5OFpwazVTdy9Ic3RlVnZvZm5qbGlLajRjNWNXbzdr
NEZUSy81dzZCcXlmSHpkcnFSRHNWbHNWOERLSUpJejBrTFJoMUFHdlQ3c1lWcXpwNUhFcnN4ZnZI
K0pEZlNVa0pUOElTWE4xSkxkcllxUjJzQVBmMjhsbVl1eXpkaGprQTNzdWZlZ2dQQWYzam1ndFFP
Q1JHWi9ZdmZKcjFLcVZIZDdvYUdOOE1Ndm9BMy9reE9iTWVCSk5ldkl5VHNwdWF2bWxGU29qMkVU
Z12RGeUphQ0FGamQ3VFF2ZXJGM0JSeUVxNDhDMUR4OTE3cWJvRVJaQXZ6elQxU0lIZHk2MG5QVHpa
OEM5akRxbzZlVmJYNk8xT05ZckViM0eYhRlmk0WkpjMWcvRi83WVA3SHVhSy91V0llb2JkN2JNRmtj
NFNhSlJxRE1JNE9ERFdzSHhKL29ZalZrL1VrU1dqSXJZTVBaUDA4VW1XaVljcHh4cFF6YmZKb3pH
bmNqMEFodUlqZzQ3blJwMTJTUWY5cDRnQ1UzK2NxdVNPQmZjTXExd0ZHcXVxMEk0ZEVIdCtiNmZi
OFpmYll1Z0lpa2xRZUlYMzQ4cnl2aFpzaVQvZ3AvRllSaFZEZTA9IG5pY2NoYXVkQGNpc2NvLmNv
bUBOSUNDSEFVRC1NLUZCVE4K#ENDKEY#`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}