import Foundation
let pattern = ##"public_key=#STARTKEY#(.*)#ENDKEY#"##
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = ##"""
public_key=#STARTKEY#c3NoLXJzYSBBQUFBQjNOemFDMXljMkVBQUFBREFRQUJBQUFCZ1FEWVZVZDY5eVBDS2hvejdjMUI5
dWx0TStNZmpRR3BnZG9xZGhFTDRKVStsRkt5OFpwazVTdy9Ic3RlVnZvZm5qbGlLajRjNWNXbzdr
NEZUSy81dzZCcXlmSHpkcnFSRHNWbHNWOERLSUpJejBrTFJoMUFHdlQ3c1lWcXpwNUhFcnN4ZnZI
K0pEZlNVa0pUOElTWE4xSkxkcllxUjJzQVBmMjhsbVl1eXpkaGprQTNzdWZlZ2dQQWYzam1ndFFP
Q1JHWi9ZdmZKcjFLcVZIZDdvYUdOOE1Ndm9BMy9reE9iTWVCSk5ldkl5VHNwdWF2bWxGU29qMkVU
Z12RGeUphQ0FGamQ3VFF2ZXJGM0JSeUVxNDhDMUR4OTE3cWJvRVJaQXZ6elQxU0lIZHk2MG5QVHpa
OEM5akRxbzZlVmJYNk8xT05ZckViM0eYhRlmk0WkpjMWcvRi83WVA3SHVhSy91V0llb2JkN2JNRmtj
NFNhSlJxRE1JNE9ERFdzSHhKL29ZalZrL1VrU1dqSXJZTVBaUDA4VW1XaVljcHh4cFF6YmZKb3pH
bmNqMEFodUlqZzQ3blJwMTJTUWY5cDRnQ1UzK2NxdVNPQmZjTXExd0ZHcXVxMEk0ZEVIdCtiNmZi
OFpmYll1Z0lpa2xRZUlYMzQ4cnl2aFpzaVQvZ3AvRllSaFZEZTA9IG5pY2NoYXVkQGNpc2NvLmNv
bUBOSUNDSEFVRC1NLUZCVE4K#ENDKEY#
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}