re = /[a-zA-Z]:\\((?:.*?\\)*).*/m
str = 'C:\\Users\\username\\Documents\\Files\\aa.xx
C:\\Users\\username\\chocolate\\Files\\aa.xx
C:\\Users\\username\\Documents\\Files\\aa.xx
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end