$re = '/^#[a-z0-9]+(?:\/[a-z0-9]+)*(?:,\s*#[a-z0-9]+(?:\/[a-z0-9]+)*)*$/m';
$str = '#abcd,#abcd/2345
#abcd
#a/b/c/d
#isfdhugiudshfgidufig/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);