re = /^#[a-z0-9]+(?:\/[a-z0-9]+)*(?:,\s*#[a-z0-9]+(?:\/[a-z0-9]+)*)*$/m
str = '#abcd,#abcd/2345
#abcd
#a/b/c/d
#isfdhugiudshfgidufig/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end