$re = '/^(http|https):\/\/([^\[\/:]+|\[[a-fA-F0-9:]+\])(?::\d+)?\/?(.*)/';
$str = 'http://spinetix.com:80/test/ok?q=1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);