const regex = /^(.*?)(\/target-)(.*?)(\.md)$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)(\\\/target-)(.*?)(\\.md)$', 'i')
const str = `/dir1/dir2/dir3/dir4/../dir7/dir8/dir9/target-.a-word1-word2-alphanumberic1-alphanumberic2.md`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}