const regex = /^(?!\d+$)[a-zA-Z0-9\'.]{5,30}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\d+$)[a-zA-Z0-9\\\'.]{5,30}$', 'gm')
const str = `12345678
12345a
123d
12345678901234567890123456789'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}