$re = '/^(?!\d+$)[a-zA-Z0-9\'.]{5,30}$/m';
$str = '12345678
12345a
123d
12345678901234567890123456789\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);