import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[Pp]ython v?(?:(?:(?<epoch>[0-9]+)!)?(?<release>[0-9]+(?:\\.[0-9]+)*)(?<pre>[-_\\.]?(?<preLabel>(a|b|c|rc|alpha|beta|pre|preview))[-_\\.]?(?<preNumber>[0-9]+)?)?(?<post>(?:-(?<postNumber0>[0-9]+))|(?:[-_\\.]?(?<postLabel>post|rev|r)[-_\\.]?(?<postNumber1>[0-9]+)?))?(?<dev>[-_\\.]?(?<devLabel>dev)[-_\\.]?(?<devNumber>[0-9]+)?)?)(?:\\+(?<local>[a-z0-9]+(?:[-_\\.][a-z0-9]+)*))?$";
final String string = "Python 2.7.15\n"
+ "python v3.6.6";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}