#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:<(?=[^<>]*>)|\[mailto:\s*(?=[^][]*]))([^\s@]+@[^\s@]+\.\w{2,})"
Local $sString = "Hello my Email Address is <foo.@hotmail.com> - Return foo@hotmail.com as Group1." & @CRLF & _
"Hello my Email Address is [mailto: foo@hotmail.com] - Return foo@hotmail.com as Group2." & @CRLF & _
"<foo.123@hotmail.com>, [mailto:foo$123@hotmail.com]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")