re = /(?:<(?=[^<>]*>)|\[mailto:\s*(?=[^][]*]))([^\s@]+@[^\s@]+\.\w{2,})/m
str = 'Hello my Email Address is <foo.@hotmail.com> - Return foo@hotmail.com as Group1.
Hello my Email Address is [mailto: foo@hotmail.com] - Return foo@hotmail.com as Group2.
<foo.123@hotmail.com>, [mailto:foo$123@hotmail.com]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end