package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(Flat\/Room|Flat|Suite|Rooms|Rm\.|Rm|Shop|Units|Unit|Offices|Office) ([\w&-]+)`)
var str = `Rm. 2301, Blk. B3-B4,
Flat/Room 5, 9/F,
rm A, 17/F.,
Flat F, 9/F,
Flat G1, 10/F,
Flat C, 36/F, Block 1,
Flat 1107&1108, 11/F,
Flat 2301, 23/F, F
Unit 3, 2/F, L
Unit 1603 16/F
Offices D-F, 23/F,
Office D-F, 23/F,
Unit 1901, 19/F,
Units A, 6/F,
Shop 14, G/F,
Rooms 2202,
Suite 702, 7/F.,
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}