import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Flat\\/Room|Flat|Suite|Rooms|Rm\\.|Rm|Shop|Units|Unit|Offices|Office) ([\\w&-]+)";
final String string = "Rm. 2301, Blk. B3-B4, \n"
+ "Flat/Room 5, 9/F, \n"
+ "rm A, 17/F., \n"
+ "Flat F, 9/F, \n"
+ "Flat G1, 10/F, \n"
+ "Flat C, 36/F, Block 1, \n"
+ "Flat 1107&1108, 11/F, \n"
+ "Flat 2301, 23/F, F\n"
+ "Unit 3, 2/F, L\n"
+ "Unit 1603 16/F \n"
+ "Offices D-F, 23/F, \n"
+ "Office D-F, 23/F, \n"
+ "Unit 1901, 19/F, \n"
+ "Units A, 6/F, \n"
+ "Shop 14, G/F, \n"
+ "Rooms 2202, \n"
+ "Suite 702, 7/F.,\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}