const regex = /DESCRIPTION(.)[^:]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('DESCRIPTION(.)[^:]*', 'g')
const str = ` DESCRIPTIONA - JONES:4:2
DESCRIPTIONB - WILDER:6:7
DESCRIPTIONA - MANN:5:8
DESCRIPTIONB - ROBERTS:3:4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}