$re = '/DESCRIPTION(.)[^:]*/';
$str = ' DESCRIPTIONA - JONES:4:2
DESCRIPTIONB - WILDER:6:7
DESCRIPTIONA - MANN:5:8
DESCRIPTIONB - ROBERTS:3:4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);