re = /(?<=Total\r?\n)(.+)\s+\d+\s+\d+\s+([A-z]{3})/m
str = 'Item Description Quantity Price Per Total
Various paper supplies 1 269033 USD 269033 USD
Subtotal: 224194 USD'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end