$re = '/(\[[^\]]*\])|(【[^】]*】)|(([^)]*))|(\([^\)]*\))/m';
$str = '你好(hh)mm(哈哈)在[hhhh]nini【jj】';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);