re = /(\[[^\]]*\])|(【[^】]*】)|(([^)]*))|(\([^\)]*\))/m
str = '你好(hh)mm(哈哈)在[hhhh]nini【jj】'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end