$re = '/\n(.{1,1})(?:.*?)\n(?!\1)/m';
$str = 'national day
national
other
random
random2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);