re = /\n(.{1,1})(?:.*?)\n(?!\1)/m
str = 'national day
national
other
random
random2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end