#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(PostgreSQL (?P<psql_major>\d{1,2})\.(?P<psql_minor>\d{1,2})(?P<psql_opt_patch>\.\d{1,2})?, )?Aurora PostgreSQL release (?P<aurora_psql_major>\d{1,2})\.(?P<aurora_psql_minor>\d{1,2})(?P<aurora_psql_opt_patch>\.\d{1,2})?(?P<release_or_deprecation>\,\s(?P<release_data>.*)|\s\(Deprecated on (?P<deprecation_date>.*)\))?"
Local $sString = "PostgreSQL 12.6, Aurora PostgreSQL release 4.1 (Deprecated on July 15, 2022)" & @CRLF & _
"PostgreSQL 12.4, Aurora PostgreSQL release 4.0 (Deprecated on July 15, 2022)" & @CRLF & _
"Aurora PostgreSQL release 14.3.1, July 6, 2022" & @CRLF & _
"PostgreSQL 9.6.8, Aurora PostgreSQL release 1.2 (Deprecated on October 28, 2021)" & @CRLF & _
"PostgreSQL 9.6.8, Aurora PostgreSQL release 1.2.4" & @CRLF & _
"PostgreSQL 14.5, Aurora PostgreSQL release 1.2" & @CRLF & _
"Aurora PostgreSQL release 14.3.1, Deprecated on October 28, 2021)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")