import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(PostgreSQL (?P<psql_major>\\d{1,2})\\.(?P<psql_minor>\\d{1,2})(?P<psql_opt_patch>\\.\\d{1,2})?, )?Aurora PostgreSQL release (?P<aurora_psql_major>\\d{1,2})\\.(?P<aurora_psql_minor>\\d{1,2})(?P<aurora_psql_opt_patch>\\.\\d{1,2})?(?P<release_or_deprecation>\\,\\s(?P<release_data>.*)|\\s\\(Deprecated on (?P<deprecation_date>.*)\\))?";
final String string = "PostgreSQL 12.6, Aurora PostgreSQL release 4.1 (Deprecated on July 15, 2022)\n"
+ "PostgreSQL 12.4, Aurora PostgreSQL release 4.0 (Deprecated on July 15, 2022)\n"
+ "Aurora PostgreSQL release 14.3.1, July 6, 2022\n"
+ "PostgreSQL 9.6.8, Aurora PostgreSQL release 1.2 (Deprecated on October 28, 2021)\n"
+ "PostgreSQL 9.6.8, Aurora PostgreSQL release 1.2.4\n"
+ "PostgreSQL 14.5, Aurora PostgreSQL release 1.2\n"
+ "Aurora PostgreSQL release 14.3.1, Deprecated on October 28, 2021)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}