package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<player>[\w ]+) (tries to )?hit(s)? (?<target>[\w ]+)`)
var str = `John the Great hits the red ball
John the Great tries to hit the red ball
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}