const regex = new RegExp('^(?<player>[\\w ]+) (tries to )?hit(s)? (?<target>[\\w ]+)', 'gm')
const str = `John the Great hits the red ball
John the Great tries to hit the red ball
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}