using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((([^)]+))\)\[(.*?)\]";
string substitution = @"[\2] (\1)";
string input = @"(Aneppoi no -my sister, like sister-)[Mogiki Hayami].cbz
(Aru Hi Totsuzen Shota ni Natte Shimatta Master no Ohanashi (decensored))[Motsuaki].cbz";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}