const regex = /\((([^)]+))\)\[(.*?)\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\((([^)]+))\\)\\[(.*?)\\]', 'g')
const str = `(Aneppoi no -my sister, like sister-)[Mogiki Hayami].cbz
(Aru Hi Totsuzen Shota ni Natte Shimatta Master no Ohanashi (decensored))[Motsuaki].cbz`;
const subst = `[\2] (\1)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);