const regex = /#(?!(?:hashtag|DoNotRemoveThis)\b)[\w-]+(?=(?:\s+#[\w-]+)*\s*$)/giu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#(?!(?:hashtag|DoNotRemoveThis)\\b)[\\w-]+(?=(?:\\s+#[\\w-]+)*\\s*$)', 'giu')
const str = `Any #hashtag in the middle of the string should NOT be removed regardless of what it is, for example #DoNotRemoveThis #KeepThisHashtag and any hashtag at the end of the string should be removed UNLESS it matches the exeptions in the regex. #deletethis #DoNotRemoveThis #thismustgoaway`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);