use strict;
my $str = 'Any #hashtag in the middle of the string should NOT be removed regardless of what it is, for example #DoNotRemoveThis #KeepThisHashtag and any hashtag at the end of the string should be removed UNLESS it matches the exeptions in the regex. #deletethis #DoNotRemoveThis #thismustgoaway';
my $regex = qr/#(?!(?:hashtag|DoNotRemoveThis)\b)[\w-]+(?=(?:\s+#[\w-]+)*\s*$)/iup;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";