package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bHelloWorld\b`)
var str = `HelloWorld is a beautiful word \nHelloWorld\nHelloWorld\nHelloWorld hello noHelloWorld \n HelloWorldno noHelloWorld HelloWorldno \nnoHelloWorld \nHelloWorld ...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}