$re = '/\bHelloWorld\b/m';
$str = 'HelloWorld is a beautiful word \\nHelloWorld\\nHelloWorld\\nHelloWorld hello noHelloWorld \\n HelloWorldno noHelloWorld HelloWorldno \\nnoHelloWorld \\nHelloWorld ...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);