$re = '/^(\d{10}|\d{12})$/m';
$str = '1234567890
123456789012
12345678901
123456
1234567890123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);