$re = '/(\d[,.])(\d{2})(?!\d)/m';
$str = 'Test test test 100,99€ test 2.116.600,99€ test € 2,50 test.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);