re = /(\d[,.])(\d{2})(?!\d)/m
str = 'Test test test 100,99€ test 2.116.600,99€ test € 2,50 test.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end