package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)NN\.[A-z]{?}\.`)
var str = `NN.KTXS/KTXE.FOO BAR.STACK.OVERFLOW`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}