$re = '/NN\.[A-z]{?}\./m';
$str = 'NN.KTXS/KTXE.FOO BAR.STACK.OVERFLOW';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);