using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ifs\(.*?\)";
string input = @"=iferror(ifs(OR(""foo"", ""bar""),""a"",OR(""tar"", ""scar""),""b"",OR(""lar""),""d""),""c"")";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}