re = /ifs\(.*?\)/i
str = '=iferror(ifs(OR("foo", "bar"),"a",OR("tar", "scar"),"b",OR("lar"),"d"),"c")'
# Print the match result
str.match(re) do |match|
puts match.to_s
end