import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<TopicSet.*?>)([\\s\\S]*?)(<\\/TopicSet>)";
final String string = "<TopicSet FormalName=\"PARENT1\">\n"
+ " <Topic>\n"
+ " <TopicType FormalName=\"Child1\" />\n"
+ " </Topic>\n"
+ " <Topic>\n"
+ " <TopicType FormalName=\"Child2\" />\n"
+ " </Topic>\n"
+ " <Topic>\n"
+ " <TopicType FormalName=\"Child3\" />\n"
+ " </Topic>\n"
+ "</TopicSet>\n"
+ "<TopicSet FormalName=\"PARENT2\">\n"
+ " <Topic>\n"
+ " <TopicType FormalName=\"Child1\" />\n"
+ " </Topic>\n"
+ " <Topic>\n"
+ " <TopicType FormalName=\"Child2\" />\n"
+ " </Topic>\n"
+ " <Topic>\n"
+ " <TopicType FormalName=\"Child3\" />\n"
+ " </Topic>\n"
+ "</TopicSet>";
final String subst = "$1$2$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}