import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https?[^\\s?]+\\?)\n"
+ "([^\\s=]+=[^\\s&]+)\n"
+ "(?:\\&([^\\s=]+=[^\\s&]+))?\n"
+ "(?:\\&([^\\s=]+=[^\\s&]+))?\n"
+ "(?:\\&([^\\s=]+=[^\\s&]+))?\n";
final String string = "https://github.com/search?utf8=%E2%9C%93&q=regex%20play&type=Repositories&ref=searchresults\n"
+ " https://github.com/search?utf8=%E2%9C%93&q=regex+play&type=Repositories&ref=searchresults&o=desc&s=updated\n";
final String subst = " \\1\\2&\\3&\\4&\\5&o=desc&s=updated";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}