using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([A-Z][A-Z0-9]*)\b[^>]*>(.*?)<\/\1>";
string input = @"<TAG a=a>one<TAG>two</TAG>one</TAG>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}