$re = '/<([A-Z][A-Z0-9]*)\b[^>]*>(.*?)<\/\1>/m';
$str = '<TAG a=a>one<TAG>two</TAG>one</TAG>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);