package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\/]*$`)
var str = `/teacher/1d6f8c8d-e303-473d-bf1a-bc684b10fd20`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}