$re = '/[^\/]*$/m';
$str = '/teacher/1d6f8c8d-e303-473d-bf1a-bc684b10fd20';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);