package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<in_out>[-+])(?<id>[\w:]+)(?:\|(?<method>[A-Z]+)\s+(?<url>/.*))?`)
var str = `+36919:60546a74:0|POST /api/v1/transactions
-36919:60546a74`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}