const regex = new RegExp('^(?<in_out>[-+])(?<id>[\\w:]+)(?:\\|(?<method>[A-Z]+)\\s+(?<url>/.*))?', 'gm')
const str = `+36919:60546a74:0|POST /api/v1/transactions
-36919:60546a74`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}